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Overview
Customers who utilize both LeanData and Outreach can initiate Outreach actions within
LeanData’s FlowBuilder interface.
Features
●
●

Add Prospect to Sequence in Outreach
Select Mailbox for automated emails

Please contact your LeanData Customer Success Manager to enable this integration.

Setting up LeanData-Outreach Integration
Prerequisites
●

Joint Customer of LeanData and Outreach
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●

●

Outreach-Salesforce sync enabled (see below for directions to enable your
Salesforce-Outreach sync and view this Outreach support article for user / system
requirements)
Salesforce field creation for Lead / Contact and User

Steps to Implement
1. Enable Outreach-Salesforce Sync
a. Field Creation and Updates Out
2. Authorize Outreach with LeanData (Salesforce Admin must complete this step)
3. Set Node Conditions
4. Add Node(s) to Graph
5. Review Edge Options

Enabling Outreach-Salesforce Sync
The Outreach-Salesforce Sync must be enabled in order for the integration to function. The
integration utilizes custom field mappings to determine the corresponding records in Outreach
and Salesforce.
Background Information on the Outreach-Salesforce Sync:
● Outreach → Salesforce: Outreach records sync to Salesforce every 60 seconds or less
● Salesforce → Outreach: Salesforce records sync to Outreach at a configured time
interval. Users can set the frequency to as small as 1 minute - note that this will use
more API calls. The limit for Outreach API calls is 5,000 per user, per hour.
● Outreach Sync Settings are described in full here.
Steps:
● Enable Sync:
○ Log into the Salesforce instance that you’d like to connect with Outreach
○ In Outreach, click your initials in the bottom left corner > Settings > Plugins >
Click “Add” at the top right corner > select Salesforce > select “Allow”
● Lead Sync Settings:
○ In Salesforce, create a text field on the Lead with 255 characters. Give it a
unique label, such as “Outreach Prospect ID.” Mark the field as read-only on the
Page Layout.
○ In Outreach, click your initials in the bottom left corner > Settings > Plugins >
Salesforce instance > Lead > Fields > Add > Select Id (Outreach Internal) in the
left column > Select the field created in the above step.
i.
Enable “Updates Out” and click “Save.”
ii.
If Salesforce is your “Source of Truth,” and you would not like Outreach
changes to update Salesforce fields, uncheck “Updates Out” for all fields,
except Id (Outreach Internal)
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○

●

In Outreach, toggle over to “Sync” from the top of the page
i.
#2, 7 (Pushing, Outbound Update) are required for this integration to
function as they populate and update the Outreach ID.
ii.
We recommend enabling #1-3, 5, 7 in the screenshot below so that
Outreach and Salesforce are in sync (Polling, Pushing, Inbound Create,
Inbound Update, and Outbound Update).

Contact Sync Settings:
○ In Salesforce, create a text field with 255 characters on the Contact object. Give
it a unique label, such as “Outreach Prospect ID.” Mark the field as read-only on
the Page Layout.
○ In Outreach, click your initials in the bottom left corner > Settings > Plugins >
Salesforce instance > Contacts > Fields > Add > Select Id (Outreach Internal) in
the left column > Select the field created in the above step.
i.
Enable “Updates Out” and click “Save.”
ii.
If Salesforce is your “Source of Truth,” and you would not like Outreach
changes to update Salesforce fields, uncheck “Updates Out” for all fields,
except Id (Outreach Internal)
○ In Outreach, toggle over to “Sync” from the top of the page
i.
#2, 8 (Pushing, Outbound Update) are required for this integration to
function as they populate and update the Outreach ID.
ii.
We recommend enabling #1-3, 5, 8 in the screenshot below so that
Outreach and Salesforce are in sync (Polling, Pushing, Inbound Create,
Inbound Update, and Outbound Update).
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●

User Sync Settings:
○ In Salesforce, create a text field on the User object with 255 characters. Give it
a unique label, such as “Outreach User ID.” Mark the field as read-only on the
Page Layout.
○ In Outreach, click your initials in the bottom left corner > Settings > Plugins >
Salesforce instance > Users > Fields > Add > Select Id (Outreach Internal) in the
left column > Select the field created in the above step.
i.
Enable “Updates Out” and click “Save.”
ii.
If Salesforce is your “Source of Truth,” and you would not like Outreach
changes to update Salesforce fields, uncheck “Updates Out” for all fields,
except Id (Outreach Internal)
○ In Outreach, toggle over to “Sync” from the top of the page
i.
#2, 7 (Pushing, Outbound Update) are required for this integration to
function as they populate and update the Outreach ID.
ii.
We recommend enabling #1-3, 5, 7 in the screenshot below so that
Outreach and Salesforce are in sync (Polling, Pushing, Inbound Create,
Inbound Update Outbound Create, and Outbound Update).
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Notes:
● Syncing:
○ Upon installation and first time mapping, Outreach may need a force a sync to
update the User Outreach IDs.
■ To force a sync, visit Settings > Users > Select All > More Actions >
Synchronize with Salesforce > Push Data up to Salesforce > Force
Update of all fields
○ For Sync Settings, Inbound Create and Update are required if you want changes
in Salesforce to sync back to Outreach, including creations and updates.
●

Errors for Salesforce-Outreach Sync:
○ If the owner of a Salesforce record is not in Outreach, the Prospect record cannot
be created. Turn on Inbound Create on Users to auto create Locked Users in
Outreach.
○ Outreach does not create a new Prospect record if one already exists with the
same email address.
○ Outreach requires an email address on the Lead / Contact record if there is an
email step in the Sequence.
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Authorizing LeanData Access in Outreach
In order to enable this integration, the Salesforce Admin must authorize LeanData’s access to
your Outreach instance. Please visit LeanData > Admin > Partner Apps -> Authorize Outreach
to view the authorization and set-up instructions.
Note: The user authorizing the tool with LeanData must have the ability to edit Remote Site
Settings. Please ensure this user has Modify All Data or Customize Application permissions.

1. Navigate to Outreach's API Request Form here.
2. In the API Use Case field:
● Paste the Callback URL found on the left side of the LeanData-Outreach authorization
page
● Paste this request into the same field: "I am requesting the Application ID and Client
Secret to set up the LeanData-Outreach Integration."
3. Outreach Authorization: Enter the App ID and Client Secret into the Outreach
Authorization section.
4. Outreach Field Mapping: Select the Salesforce fields created above on the Lead,
Contact, and User that were mapped to the Outreach ID in Outreach. Confirm that the
right settings were configured in Outreach.
a. The Lead, Contact, and User field mapping is required. If you are not using any
of the objects for Routing, please create a placeholder field for the object for
mapping purposes.
b. If the mapping is incorrectly configured (e.g. the wrong Lead field is mapped to
an Outreach field), LeanData will mark it as an error and revert back any actions
in the path for the record.
5. Retry Action In: Populate this field with the number of minutes / hours / days LeanData
should wait after a failure before retrying the action. Only records with certain criteria
qualify for retries. Those that qualify will fail indefinitely after six more failed attempts.
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Outreach Sequence & Mailbox Setup
●

To add a Prospect to a Sequence in LeanData FlowBuilder, “Shared with Org” must be
set to “Others can see it and use it” on the Sequence.
○ Note: Before publicly sharing the Sequences, confirm there is no sensitive
information being exposed to employees via Sequences.
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●

Mailboxes must be enabled for all users sending automated emails in Outreach.
○
○

In Outreach, click your initials in the bottom left corner > Mailboxes > Set up
Account > Select the Email Provider > Fill out details.
Toggle on “Enable sending messages from this mailbox” and “Enable syncing
messages from this mailbox.”

Add to Sequence Node in FlowBuilder
You can add an “Add to Sequence” Action from the Partner -> Outreach Section in the
Flowbuilder interface.

Within the Add to Sequence Node, there are a few configurable options.
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Sequence Assignment: You can select any Public Sequence (any Sequence marked as
Others can see it and use it) from Outreach. If you create Outreach Sequences while you are in
a LeanData session, you can refresh the Sequences to update the list.
Mailbox for Email Delivery: This designates the user mailbox “sending” automated emails in
Sequences. The “From:” field will display the Outreach user’s default mailbox email address in
the automated emails.
● Lead or Contact Owner: this will set the Salesforce record owner as the sender in
emails. Ensure that all potential Salesforce record owners have Outreach user accounts
and Mailboxes enabled.
○ V1 of this integration does not accommodate Queues as Salesforce record
owners
● User Field on Lead or Contact: this will set the Salesforce user populated in the
designated Salesforce User field as the sender in emails.
○ To set the sender as the Outreach Prospect Owner, map the Owner field in
Outreach to the Owner field in Salesforce. Visit Settings > Plugins > Salesforce >
Lead and Contact > Fields > Map Prospect “Owner” to a Salesforce field on the
Lead and Contact > Check “Updates Out.”
● Specific User: this will display a list of all Outreach Users with Mailbox Send and Sync
enabled. If you create or enable Send / Sync for new Outreach users while you are in a
LeanData session, refresh to update the list of available user mailboxes.
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Notes:
● Convert Lead + “Add to Sequence” Behavior: When a Lead is successfully converted
to a Contact, LeanData will add the related Contact to the designated Sequence.
○ If utilizing the Convert Lead node, ensure the mapping of Salesforce fields to
Outreach fields in LeanData Partner settings is complete for Contacts.
● “Merge Dupe” + “Add to Sequence” Behavior: LeanData will NOT add the Prospect
to a Sequence if a “Merge Dupe” node is in the same path as the “Add to Sequence”
Node.

Node Placement & Edge Options
Node Placement: Depending on sync direction, different triggers or conditions should be
utilized with the “Add to Sequence” node.
● Salesforce > Outreach: If your sync settings are set up where Leads or Contacts are
created in Salesforce then synced over to Outreach, use the “Updated Lead / Contact”
trigger node or condition of “Outreach Prospect ID” as has changed / is not null.
● Outreach > Salesforce: If your sync settings are set up where Prospects are created in
Outreach then synced over to Salesforce, use the “New Lead / Contact” trigger node or
the condition of “Outreach Prospect ID” is not null.
● Salesforce <> Outreach: If bi-directional sync is on, then configure using both of the
options above.
Edge Options: Users have the ability to choose the next node LeanData should move onto if
there’s one of the below errors
● Configuration Error: the authorization for Outreach is invalid
● Missing Prospect ID: the Outreach ID is missing on the Lead or Contact
● Missing User ID: the Outreach ID is missing on the User (the user for mailbox selection)
● Queue Owner: the record is Queue-owned and the mailbox selected is the Lead /
Contact Owner
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Monitoring and Troubleshooting
Audit Logs
Outreach actions are included in LeanData Audit Logs

In some cases, LeanData cannot perform the requested actions in Outreach.
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Audit Log Filters: You can filter your Audit logs by the Outcome of the Outreach action,
specifically: Outreach - Success (Outreach), Pending (Outreach), Error (Outreach). Note that
the Error (Fallback) Outcome filter will not show any Outreach Fallback errors at this time.
Pending (Outreach): If LeanData cannot perform the requested action in Outreach, we will try
again after the amount of time set in your Partner App settings. At that point of time, the record
will be set to “Pending” in the Audit Logs. Records will remain in the “Pending” state until
ultimate failure or success.
Error (Outreach): After six retries, LeanData will mark the records as an error for the Outreach
portion of the Path in the Audit Logs.
● Both Pending records and Error records will display the audit trail of each attempt to
complete the action.
● If LeanData follows an edge (ex: Queue Owner), it will mark the node in the Path as an
Error and will not show an error message in the Outcome column
● If LeanData cannot perform the requested action because of misconfigured settings (ex:
incorrect field mapping on the LeanData set up for Outreach) or unexpected issues, we
will revert back any changes made on the record in the path.
● If LeanData cannot perform the requested action because of a callout error, only the
action of adding a Prospect to a Sequence will fail.

LeanData Partner Logs Report
Visit Reports > LeanData Reports > LeanData Partner Logs Report to view a summary of all
callouts in Salesforce reports.
● Action Type: the type of Partner node used (“Add to Sequence” for this integration)
● Node Name: the customizable name on the Outreach node
● Response Status Code: the callout status
○ 200: Callout succeeded
○ 0, 300, 400: Callout failed
○ Blank: Pending
● Target Object: the object acted upon
● Callout History: displays all responses from the callouts (includes success and failures)
● Callout Duration in milliseconds: Callout end time - Callout start time
● Total Callout Duration in milliseconds: the entire length of time it took to process the
request
● Failure Reasons: reason(s) the callout failed
○ Token is not valid
○ Partner not authorized
○ Object has been deleted
○ Object has been merged
○ Retry attempt exceeded
○ Log length hit
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The “LD Read Only” Permission Set must be added to any users who would like to
access this report.
Notes:
● Rate Limits are 5,000 requests per user per hour
● Only fields mapped in the “fields” section of the Outreach Plugin Settings will be pushed
to Salesforce.
● LeanData will wait for up to 30 seconds to accumulate callouts before running a batch to
perform Outreach Actions. LeanData will track the readiness of the callout before
initiating the callout batch.

Troubleshooting
Below is a list of common errors and reasons an action may be in a pending / error state:
Troubleshooting Steps

Error Description
Unauthorized OAuth
Scope for Outreach

1. Determine the user authorized for the LeanData Outreach integration under Admin >
Partner Apps > Outreach
2. Ensure their scope is set to sequences.all, sequenceStates.all, mailboxes.all,
prospects.all

1. Determine the user authorized for the LeanData Outreach integration under Admin >
Partner Apps > Outreach
2. In Outreach, navigate to User Admin > Profiles > Profile of User who authorized
Unauthorized Request in integration and check that these options are enabled
Outreach
- Administration: Permit Plugins
- Record Visibility: Permit all record visibility for Prospects, Accounts
- Sequences: Permit Create, Edit, Enable Sequences, Sharing Sequences
- Mailboxes: Send from all records
1. Check the Outreach node in FlowBuilder for the mailbox settings.
- If it's configured to Salesforce record owner, check the record owner name and
whether they have a user record in Outreach
2. Check the Salesforce record in question for an Outreach ID populated (If not, that
means the record was not created in Outreach or did not sync back to Salesforce).
3. Ensure nodes are correctly placed. See the Node Placement steps for more details.
Resource Not Found in
Outreach

For Outreach ID:
1. Check the Salesforce Plugin Settings in Outreach
2. Ensure the Outreach (Internal Id) is mapped to a field in Salesforce and that "Updates
Out" is enabled for all objects (User and Lead/Contact).
3. Check the Outreach Settings for Polling Frequency for all objects.
4. Check the LeanData Partner App settings for Outreach and the same field mapping is
configured.
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If it still fails, contact support@outreach.io for assistance on the Sync.
General Outreach
Validation Error

Prospect already
targeted in Outreach

1. Details on custom validation errors set up in your organization that block additions to
Sequences will be listed on the error message. Take action in accordance with your
organization policies.
1. The Sequence Ruleset Safety Settings blocked the addition of this Prospect to the
Sequence. Customers need to update the "Prospect can be added to this sequence"
field.
* Note that any Sequence on this Ruleset will also be affected so this change should not
be taken lightly.

Prospect still active in
Sequence

1. The Sequence Ruleset Safety Settings blocked the addition of this Prospect to the
Sequence. Customers need to update the "Prospect can be added to this sequence"
field.
* Note that any Sequence on this Ruleset will also be affected so this change should not
be taken lightly.

Prospect active in
another Outreach
sequence

1. The Sequence Ruleset Safety Settings blocked the addition of this Prospect to the
Sequence. Customers need to update the "Should active prospects be exclusive to this
sequence?" to the "Yes, but only for exclusive sequences" option on the Sequence the
Prospect is already lined up in.
* Note that any Sequence on this Ruleset will also be affected so this change should not
be taken lightly.

Prospect active in
another exclusive
sequence

1. The Sequence Ruleset Safety Settings blocked the addition of this Prospect to the
Sequence. Customers need to update the "Should active prospects be exclusive to this
sequence?" to "Yes" on the Sequence the Prospect is already lined up in.
* Note that any Sequence on this Ruleset will also be affected so this change should not
be taken lightly.

Prospect is locked in
Outreach

1. Unlock the Prospect if it was mistakenly locked. Ignore otherwise.

Prospect missing email
in Outreach

1. Find the Prospect in Outreach and add an email.

Prospect opted out

1. If you believe this is a mistaken "Opt Out," navigate to the Outreach Record, click the
arrow next to Edit and select "Revert Opt Out"

Outreach User is not the
1. Set Sequence Org Sharing Settings to Public.
owner
Outreach User is locked

1. If the User should be unlocked, navigate to Outreach's User Admin > Users > Select
the User > Click the ... button > Unlock.
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Outreach Mailbox does
not have send enabled

1. This error will only happen when the Mailbox Settings for the Outreach integration
node is set to "Salesforce Record Owner" and the user does not have send enabled on
the Mailbox. Find the record owner's name and have them set up the Mailbox as
outlined in the Documentation.
"In Outreach, click your initials in the bottom left corner > Mailboxes > Add > Select the
Email Provider > Fill out details. Toggle on “Enable sending messages from this
mailbox.”

Outreach Mailbox has
invalid send credentials

1. The Outreach User's default mailbox has invalid send credentials. Determine the user
and have them "disconnect" then reconnect their email account under Outreach
Mailboxes (User Admin > Mailboxes).
Failed due to Outreach API usage limits (fixed limit of 5,000 requests per one-hour
period). LeanData will retry the request after {X-RateLimit-Reset}.

Outreach Rate Limit
Exceeded

1. Change the time interval in both Outreach and LeanData settings to a higher value so
that less calls are made each hour.
* Note that this means it will take more time to sync records between Salesforce and
Outreach and to add Prospects to Sequences from LeanData.

Scheduled Outreach
Maintenance

Failed due to Outreach maintenance. LeanData will retry the request after {Retry-After}.
1. No action needed. LeanData will retry the action on the date / time designated.

Appendix
FAQ
For a list of frequently asked questions, please see here.

Roadmap Features (V2 and on)
●
●
●
●

Routing insights for “Add to Sequence” successes and failures
Error (Fallback) Filter in Audit Logs to include Outreach Errors
Update Prospect Sequence State in Outreach node (Pause, Resume, Finish etc.)
User-Sequence Mapping (Select a primary Sequence for each User and route to it
automatically when the User owns a Prospect)

Please email integrations@leandatainc.com if you have any requests or feedback.

Definitions
●

Sequence
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○
○

A set of scheduled and potentially automated sales activities in Outreach
Sequence overview written by Outreach can be found here

●

Sequence Safety Rulesets
○ Sequence Exclusivity: Determines whether a Prospect can be in other
non-exclusive Sequences or other Sequences while in the current Sequence
○ Prospect Additions to Sequences: Determines the number of times a Prospect
can be added to a Sequence
○ Sequence Safety Rulesets Overview can be found here. Sequence Exclusivity
Settings can be found here
○ Found under Settings > System Config > Rulesets

●

Prospects
○ The Outreach equivalent of Leads or Contacts in Salesforce

●

Prospect Stages
○ These are 1:1 with Salesforce Stages. Outreach can automatically set Prospect
Stages based off of Sequence actions
○ The Prospect Stage Overview can be found here

●

Prospect Sequence State:
○ The Prospect’s state in a Sequence.
○ Definitions of each Sequence State can be found here.
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