FAQ: Why is a user still being assigned records while on a vacation?

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Overview

When you set a vacation schedule for a user in LeanData, you can prevent them from receiving records or meetings while they're away. If users still receive assignments during their vacation, this guide will help you troubleshoot the issue.

For more information on Users and Schedules please see the Schedules and People guide.

 

Common Causes 

If you have a vacation schedule set but still receive record assignments, it's likely due to one of these issues:

  • Vacation schedule is not active or incorrectly configured.
  • The routing node or Round Robin pool is not set to respect vacation schedules.
  • The "Vacations" option is not checked in the "Respect User Schedules" section of the node.
  • The vacation start and end dates don't match your intended time away.

 

Troubleshooting Steps

1. Verify Your Vacation Schedule Settings

  • Navigate to LeanData instance > People > Users > Select user > Schedule > Vacations
  • Verify that:
    • Start Date/Time is correct.
    • End Date/Time covers your full absence.
    • Date Modified shows the most recent update.

2. Check If the Assignment Was Manual

  • Check the record's SFDC history or LeanData audit logs.
  • If another user or admin manually assigned the record, the vacation schedule will not prevent the assignment.

3. Check the Trigger Action on Audit logs

  • Check if the Trigger Action is:
    • One-Time Routing
    • Insert/Update
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  • When the Trigger Action is One-Time Routing
    • Verify that the Routing Scheduler job is configured to respect user vacation schedules.
    • If not, the system may assign records even while the user is on vacation.
    • For more details, see: Routing Scheduler FAQ - Respect Schedules.
  • When the Trigger Action is Insert or Update
    • Verify the node that assigned the record:

    • Open the routing deployment.

    • Navigate to the node used for assignment.

    • Ensure the node is configured to respect the user’s vacation schedule.

  • When the record is Assigned via a Round Robin Pool
    • Navigate to: LeanData App > Round Robin > Pools > Select Pool > General

    • Check that “Respect User Schedule” is enabled.

    • If this option is not enabled, users on vacation may still receive assignments.

Note: When merging duplicate records, the user retained will be determined by the merge duplicate settings, and vacation schedules will not be respected.

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